[opgelost] CHRCH via website, niet meer in frame?

Behalve via de app, hebben we ook op de website de mogelijkheid gecreëerd om op CHRCH in te loggen (met dank aan anderen in dit forum). Dit gaat al maandenlang prima. maar sinds maandag is dat niet meer mogelijk. Een bewuste keuze, of moet mijn vraag naar de categorie: Bug?

Ik heb wat wijzigingen aan de configuratie gemaakt om de veiligheid te verbeteren, dat was eerder dan maandag maar zou ermee te maken kunnen hebben. Dit gevolg is onbedoeld. Het zou ook het gevolg van een browserupdate kunnen zijn. Zou je de link kunnen delen? Ik duik er dan even in.

Mijn iframe op https://mijnkerkleden.nl werkt nog steeds in Chromium, maar niet meer in Firefox:

Versies:
Chromium: Versie 80.0.3987.163 (Officiële build) Built on Ubuntu , running on LinuxMint 19.1 (64-bits)
Firefox: 75.0 (64-bits)

Update: Google Chrome Versie 80.0.3987.163 (Officiële build) (32-bits) en Versie 81.0.4044.122 (Officiële build) (32-bits) onder Windows doen het ook niet: “api.chrch.org heeft de verbinding geweigerd”.

Dank @Efkasoft!

Inmiddels heb ik dit weggehaald in de configuratie:
add_header X-Frame-Options SAMEORIGIN;
Dat zorgt ervoor dat inframen weer mogelijk is. Ik heb een lijstje best practices geïmplementeerd waar dit er een van was.

Link naar de app op website
https://pkn-neede.nl/website/home/chrch-app

Op Win 10 - 64 bits

  • Met Opera (versie 67.x.xx. en 68.x.x) en Chrome (versie 80.x.x en 81.x.x) dezelfde foutmelding
  • (Getriggerd door Efkasoft) ook gekeken met Edge (versie 80); daar werkt het wel

Degene die de website beheert:
Eveneens Win 10, 64 bits:

  • Edge 44.18362.449.0 (werkte niet bij hem)
  • Chrome: 81.0.4044.113 (werkt wel)
  • Firefox: 75.0 (werkt wel)

Hij suggereert dat het een cacheprobleem is.
En inderdaad bij mij in privé-modus bij Opera en Chrome werkt het dan al wel.
En na het legen van de cache ook in de gewone modus.

Probleem opgelost. Bedankt @peterarends